Error IMP-00021 during Import
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 8 of 8

Thread: Error IMP-00021 during Import

Hybrid View

  1. #1
    Join Date
    Sep 2001
    Posts
    34

    Unhappy

    Hello,

    Since one week, i try to import a database. This DB is located on a server which contains

    the Oracle 8.1.5 Version on WINDOWS NT 4. My computer contains the 8.1.5 and 8.1.7 Versions

    and is installed with WINDOWS 2000 Professionnal OS.

    When i launch the exp procedure, all is good. It terminate successfully. (i use the 8.1.5

    exp utility). This is my parameters file which is launch by this command line :
    ------------------------------------------------------
    c:\oracle\ora815\bin\exp user/pwd@test parfile=EXP.par
    ------------------------------------------------------

    FILE PARAMETER :
    ---------------------
    FILE=EXP_DATAFILE.DMP
    LOG=EXPFILE.LOG
    FULL=Y
    INCTYPE = COMPLETE
    STATISTICS = NONE
    ---------------------

    One datafile "EXP_DATAFILE" is created.

    But when i execute the comand line :
    ----------------------------------------------------------------
    c:\oracle\ora815\bin\imp user/pwd@local PARFILE = imp.PAR
    ----------------------------------------------------------------

    Which uses this parameters file :

    FILE PARAMETER :
    ------------------------
    FILE=EXP_DATAFILE.DMP
    LOG=IMPFILE.LOG
    FROMUSER=MANAGER
    TOUSER=MANAGER
    IGNORE=Y
    ANALYZE=N
    RECALCULATE_STATISTICS=N
    SHOW=N
    ROWS=Y
    ------------------------

    , an error occurs.


    See the log file generated by the imp procedure :

    ------------------------------------------------------------------------------
    Connected to: Oracle8i Enterprise Edition Release 8.1.7.0.0 - Production
    JServer Release 8.1.7.0.0 - Production

    Export file created by EXPORT:V08.01.05 via conventional path

    Warning: the objects were exported by SYSTEM, not by you

    import done in WE8ISO8859P1 character set and WE8ISO8859P1 NCHAR character set
    . . importing table "ADDRESSES" 1973 rows imported
    . . importing table "ASSIGNMENT" 79442 rows imported
    IMP-00017: following statement failed with ORACLE error 3113:
    "CREATE INDEX "ASSIGNMENT_I_01" ON "ASSIGNMENT" ("CPID" , "CUSTOMERID" ) PC"
    "TFREE 10 INITRANS 2 MAXTRANS 255 STORAGE(INITIAL 9625600 NEXT 106496 MINEXT"
    "ENTS 1 MAXEXTENTS 121 PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_PO"
    "OL DEFAULT) TABLESPACE "GMS_TABLESPACE" LOGGING"
    IMP-00003: ORACLE error 3113 encountered
    ORA-03113: end-of-file on communication channel
    IMP-00021: operating system error - error code (dec 2, hex 0x2)
    IMP-00000: Import terminated unsuccessfully

    IMP-00021: operating system error - error code (dec 2, hex 0x2)
    ------------------------------------------------------------------------------

    NB : tablespaces and the user used to import datafile are the same that tablespaces and

    users employed in source database (type, name, size, characteristics, ... )


    Can you explain me why this error occurs or how can i resolve it ?? !!!


  2. #2
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    Are you trying to import 8.1.5 to 8.1.7 on such case, I would suggest that you use 8.1.5's imp. One other thing and to increase your swap space and see whether it goes through.

    Sam
    Thanx
    Sam



    Life is a journey, not a destination!


  3. #3
    Join Date
    Sep 2001
    Posts
    34

    Exclamation

    Thanks but i've already tried to use both 8.1.5 utilities. But it doesn't work.

    Another solution ? !!!!!


  4. #4
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    Did you increase your swap sapce and try?


    Sam
    Thanx
    Sam



    Life is a journey, not a destination!


  5. #5
    Join Date
    Sep 2001
    Posts
    34

    Exclamation

    Yes, of course.
    I've already changed many parameters : SGA allocated, Tablespaces' size, blocks' size...
    Nothing change the situation.

    But I've noticed that if I use 817 utilities, the imp-00021 error doesn't appear. But the imp procedure stops at the same moment...

    Thanks for your responses :-)))))

  6. #6
    Join Date
    Apr 2001
    Location
    Brisbane, Queensland, Australia
    Posts
    1,203
    Maybe some type of corruption in your export file. Try exporting the data again.
    OCP 8i, 9i DBA
    Brisbane Australia

  7. #7
    Join Date
    Sep 2001
    Posts
    34

    Exclamation

    I already try to export data many times.

    I try to launch exp procedure from server and from my computer.

    I obtain the same result...


  8. #8
    Join Date
    Apr 2001
    Location
    Czechia
    Posts
    712
    Just some (maybe silly) ideas ...
    See if trace file was generated.
    Try bypass Net8: make sure 8.1.5 database is default on your computer and call imp without specifying "@local".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width