disable constraint error - Please Help!!
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: disable constraint error - Please Help!!

  1. #1
    Join Date
    Jun 2000
    Location
    dumfries,va,usa
    Posts
    227
    Hi,
    I'm trying to disable a constraint but I get this error message anytime I issue the command:

    SVRMGR> alter table om_account disable constraint OM.SYS_C00922;
    alter table om_account disable constraint OM.SYS_C00922
    *
    ORA-00933: SQL command not properly ended


    Could someone please help me correct this problem.


    Thanks,
    Leonard905
    leonard905
    leonard905@yahoo.com

  2. #2
    Join Date
    Nov 2000
    Location
    greenwich.ct.us
    Posts
    9,095
    try
    Code:
    alter table om_account modify constraint OM.SYS_C00922 disable;
    See http://technet.oracle.com/docs/produ...4a.htm#2060791 and http://technet.oracle.com/docs/produ...2a.htm#2054899 for details.
    Jeff Hunter
    marist89@yahoo.com
    http://marist89.blogspot.com/
    Get Firefox!
    "I pledge to stop eating sharks fin soup and will not do so under any circumstances."

  3. #3
    Join Date
    Apr 2001
    Location
    UK
    Posts
    137
    I don't think you're allowed a username in the constraint clause. Try:

    alter table om_account disable constraint SYS_C00922


  4. #4
    Join Date
    Jun 2000
    Location
    dumfries,va,usa
    Posts
    227
    Thanks, though. But none of the suggestions worked. Any more suggestions.
    leonard905
    leonard905@yahoo.com

  5. #5
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    Originally posted by leonard905
    Hi,
    I'm trying to disable a constraint but I get this error message anytime I issue the command:

    SVRMGR> alter table om_account disable constraint OM.SYS_C00922;
    ALTER TABLE schema.object_name
    DISABLE CONSTRAINT schema.constratint;

    In your case it looks like it is a primary/unique key constraint. So it would be

    ALTER TABLE schema.table_name
    DISABLE PRIMARY KEY;


    ALTER TABLE schema.table_name
    DISABLE UNIQUE (col1, ...) CASCADE;



    Hope this would help you. I could be wrong in the syntax assumption ...

    Sam
    Thanx
    Sam



    Life is a journey, not a destination!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width