Turning Off Archive Logs
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 7 of 7

Thread: Turning Off Archive Logs

  1. #1
    Join Date
    Apr 2001
    Posts
    55

    Can anyone tell me the proper way to turn off archive logging as I've tried a couple of ways both of which have caused me problems.

    Please help

  2. #2
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,448
    you have to stop the arch process (comment the log_archive_start parameter in init.ora) shutdown the database, startup mount

    alter database noarchive log;

    alter database open

    check archive mode by issuing

    archive log list

    you should see

    database log mode no archive mode
    automatic archival disabled

  3. #3
    Join Date
    Sep 2001
    Location
    Fort Smith
    Posts
    184
    comment archive parameters in init.ora file or set the archive start to false. this becomes effective when the instance is restarted and for immediate use issue shutdown the database, startup mount
    alter database noarchive log;
    alter database open
    which sets the mode of database to noarchive log mode.
    You, thus, do 2 things 1. set the automatic archive to false and then alter the database mode to noarchivelog


    sonofsita
    http://www.ordba.net

  4. #4
    Join Date
    Jun 2001
    Location
    Helsinki. Finland
    Posts
    3,938
    Do you want to turn off the archive process in a production env.? Why woud you want your DB to run in noarchive mode?




  5. #5
    Join Date
    Sep 2001
    Location
    Makati, Philippines
    Posts
    857
    follow those instructions and
    try to force a switch of logfile before you
    restart your database:
    svrmgrl> alter system switch logfile;

    then shutdown and restart your database with the
    initSID.ora configuration.

    regards

  6. #6
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,448
    why do you have to force log switch?

  7. #7
    Join Date
    Sep 2001
    Location
    Makati, Philippines
    Posts
    857
    This is only if the usual step of turning of the archive log mode doesn't seem to work.

    'cause I have already encountered this problem long time ago and I just
    can't remember what version was it and in what platform although
    I follow what Oracle Documentation says about turning the archive
    log mode and sure there was a missing piece of this set of commands with my situation at that time.

    And I believe he's undergoing the same problem. I think so.
    It seems to me at that time that, the thread information of the controlfile
    and datafile header seems not to synchronize with the checkpoint information,
    archiving status with the SCN being used when the archiving was disabled. Perhaps,
    being used in instance recovery or crash recovery.

    I am sure the step of disabling archiving that you guys mentioned works well.
    I just thought that HUMMY perhaps experienced what I did before.

    Keep it cool.

    regards


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width