DBAsupport.com Forums - Powered by vBulletin
Results 1 to 3 of 3
  1. #1
    Join Date
    May 2001


    Hi There,

    Was wondering where do i need to post this query in this forum.

    Well...The problem i have been facing recently is as follows:

    I installed just the Runtime components of the Oracle Developer 6.0 software which incl. Forms Runtime, Reports Runtime, Graphics Runtime and a little more of some related files to support the execution of the complied executable forms / Reports.

    The problem which is now bugging me a lot off late is that when i try to run an Oracle Reports in this machine where i have just installed the Oracle Developer Runtime components alone, i get a peculiar error

    "REP-108: File RWBDEXPQ.res file not found".

    From the name of the file i recon its a resource file that has something to do with Report Builder component and kept me wondering why is this stopping me from a smooth execution while trying to run in a Runtime environment?

    Secondly, I tried copying this file from a machine which has got the entire components of Oracle Developer Installation to the same location as found in the machine to the test machine and now the error is bit descriptive but adds the same meaning...

    In both the above case, after acknowledging this error, i get the report generated as per requirement.

    My query is,

    is there a way that i can overcome this problem of this popup message which bugs up while executing Oracle Reports in a machine with just the Runtime components....

    Any valuable suggestion r welcome...


  2. #2
    Join Date
    Nov 2000

    An Oracle bug

    This is a known bug. Check the metalink for the patch. I believe an option is to install Report Builder, just installing the missing file doesn't work.

  3. #3
    Join Date
    May 2001

    Wink Finding / Solution - Work around Instaead of reinstalling the patch

    Thanx CBW...

    I wasn't aware of this bug...But i had posted the same problem sometime back in the same forum but no one had reverted back and hence i tried to detail it a bit again...

    Now i did find some workaround instead of installing the patch which u had mentioned.


    Just sorted out the work around for this problem...

    It seems really absurd that a resource file which has something to do with the Report Builder has got some link with the runtime components in the release of Oracle Developer 6.0.

    The solution which i could give would b such a pivotal and prelim. but thats how things work out if u have some high expectations on them professional software...


    I tried to run my RDF file from the command line using the RWRUN60 command.

    Initally i did just mention the REPORT, USERID, DESNAME, DESTYPE, DESFORMAT (in case of bit mapped based reports). I got the message box displaying an informative warning error message "REP-108: File rwbdexpq not found".But the report generation was absolutely as per my requirements

    Later in the run on various analsyse I included a parameter BACKGROUND=YES and this subsided this message box but instead wrote into a log file.

    Also tried giving BATCH=YES which proved positive to my approach but wrote the error to the same reports.log file.

    In this case i need to alter my source code where i have to now incl. either one of this parameters and recompile them.

    Also, while analysisng more into the Reports i found the default option set by Oracle in the SYSTEM PARAMETER of the RDF for BACKGROUND was set to NO and no one had the idea to change any default settings assigned by Oracle and this was the main culprit that was casuing all this bugging result.

    But I guess people in Oracle would have come across this bug and have silently rectificed in their next release Oracle Developer 6i in which it runs OK and perfect even though the parameter BATCH or the BACKGROUND is not given in its RWRUN60 command and also no messages were reported in the log file as well.

    Thanx a lot guys for having looked into this issue.

    Kevin (isaad@rediffmail.com)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width