sqlplus error message
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 9 of 9

Thread: sqlplus error message

  1. #1
    Join Date
    Jan 2001
    Posts
    91
    I just istalled oracle 8.1.7 r3 on on solaris 8 intel when I try to execute SqLplus I get the following error message not found..

    how can a fix ths?? I'm getting this messsage while logged on as oracle


    $ sqlplus
    /bin/ksh: sqlplus: not found
    $

  2. #2
    Join Date
    Nov 2000
    Location
    greenwich.ct.us
    Posts
    9,092
    You don't have sqlplus in your path. Make sure your oracle environment is setup from oraenv. Make sure you have $ORACLE_HOME/bin in your PATH.
    Jeff Hunter
    marist89@yahoo.com
    http://marist89.blogspot.com/
    Get Firefox!
    "I pledge to stop eating sharks fin soup and will not do so under any circumstances."

  3. #3
    Join Date
    Feb 2000
    Location
    NJ, United States
    Posts
    250
    Go to ORACLE_HOME/bin and try to invoke sqlplus from there,it should work.

    The environment is not set. you have to add the $oracle_home/bin to PATH variable.
    export PATH=$PATH:$ORACLE_HOME/bin

    Hope this helps.
    Kavita
    KN

  4. #4
    Join Date
    Jan 2001
    Posts
    91

    sqlplus error message

    Marist I will give this a shot I will let you what happens..


    Thanks

    Tim

  5. #5
    Join Date
    Jan 2001
    Posts
    91

    error in Sqlplus

    Knarayan, I tried to execute SQLPLUS from the bin directory and I got the following error message



    $ sqlplus
    Message file sp1.msb not found
    Error 6 initializing SQL*Plus
    $



  6. #6
    Join Date
    Nov 2000
    Location
    greenwich.ct.us
    Posts
    9,092
    Your environment is not setup correctly. You will want to find your oraenv script. This will help you setup your environment. Usually, the oraenv script is in your local bin directory (/usr/local/bin or /opt/bin). If you are a ksh or sh user, enter the following command:
    Code:
    # . oraenv
    If you are a csh user, you will want to:
    Code:
    # source coraenv
    Jeff Hunter
    marist89@yahoo.com
    http://marist89.blogspot.com/
    Get Firefox!
    "I pledge to stop eating sharks fin soup and will not do so under any circumstances."

  7. #7
    Join Date
    Sep 2000
    Posts
    155
    Jeff,

    I am getting a similar message now.
    I have just installed Oracle 8.1.6 on Linux.

    All my environment settings/vairables seems
    to be good. I have double checked them.

    In fact, when I tried to execute sqlplus from $ORACLE_HOME/bin
    directory, I still get the same message
    Any suggestions???


    TIA

  8. #8
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    Set your

    ORACLE_HOME=.../8.1.6
    export ORACLE_HOME

    PATH=$ORACLE_HOME/bin:$PATH;
    export PATH

    LD_LIBRARY_PARH=$ORACLE_HOME/lib
    export LD_LIBRARY_PATH

    Remember the above is for the born/k/bash shells

    If the shell is C shell, you have to use setenv.

    If these doesn't get to be fruit full, post your env

    $ env

    Remember to blank your host/IP addresses from your posting

    Sam

    [Edited by sambavan on 10-01-2001 at 05:56 PM]
    Thanx
    Sam



    Life is a journey, not a destination!


  9. #9
    Join Date
    Sep 2000
    Posts
    155
    Thanks!
    I got this working.

    The problem (I figured it out) was, after declaring the
    variables, I was not exporting them....silly stuff...
    Wonder what I was thinking

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width