DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: how to import table to a new new table space

  1. #1
    Join Date
    Jul 2001
    Hello, i have an export file in /exports/full_20010729.dmp and I would like to import this into a instance called prdw, this comes about form a problem that I have had ealier this month, my table became lock with an in-doubt transation and we tried everything that you guys suggested but still no luck. so I would like to put the table back the way it was before this happened.

    I tried to import the table but it says unable to create intial extent for segment in table space dta_rel_erwkshft. I renamed the old table, but do I have to drop it in order to get rid of the old table space? Is the problem that the same table space still exsists? what would happened if I were to restore the file to which the table space points to, would that restore the table to way it was before, would that get rid of the lock on my rows?

    I have tried

    imp dwprd/dwprd@prdw file=/exports/full_20010729.dmp ignore =n full=n tables= ER_WORK_SHIFTS

    it tries to do the import but then says it is skipping table ER_WORK_SHIFTS and says the import finished successfully without warnings

    Could some body help me out, thanks

    Scott Power

  2. #2
    Join Date
    Jan 2001


    You may want to truncate that table before inserting data into it, that is what I do. It is also a good idea to back up the table before you truncate it. It could also be that you have
    ignore= n, come to think of it, this is probably your problem.
    try setting it to =Y

  3. #3
    Join Date
    Jul 2001
    I tried setting ignore to yes and it still says teh same error, unable to create inital segment for tablespace....

    Got any more ideas???


  4. #4
    Join Date
    Feb 2001
    Kolkata- India
    All I can think of is your tablespace is full so when you took and export it must have been compress=y so when you are importing it back it is unable to allocate a large extent in the tablespace. Try adding a datafile to the tablespace.
    There Nothing You cannot Do, The problem is HOW.

  5. #5
    Join Date
    Nov 2000
    Originally posted by spower
    unable to create inital segment for tablespace....
    You are getting this error because there is no extent large enough in your target tablespace that will hold the INITIAL extent. You could either add more space to your tablespace or pre-create your table and import with ignore=y.

    To pre-create your table, add the indexfile option to the exp command:
    exp system/yourpw@yourdb file=yourexpfile.dmp indexfile=yourdb.sql tables=...

    Then, in yourdb.sql will be a bunch of DDL that you can edit and pre-create your tables.
    Jeff Hunter
    Get Firefox!
    "I pledge to stop eating sharks fin soup and will not do so under any circumstances."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width