Listener is not running
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 4 of 4

Thread: Listener is not running

  1. #1
    Join Date
    Feb 2000
    Location
    New York,U.S.A.
    Posts
    245
    Hi,
    I have two production databases running on Veritas Cluster Server. the two databases can connect to each other. Since last Tuesday, it stopped working for connecting from one to the other. When I do tnsping SID, it shows
    Attempting to contact (ADDRESS=(PROTOCOL=TCP)(HOST=hubdb)(PORT=1521))
    TNS-12541: TNS:no listener

    But when I go to the other database and do a lsnrctl status, it shows listener is working and I can connect from another server to this database too. I went to ask my SA if he made any changes to the database and he said no changes were made to the database. From tnsping, it only shows TNS-12541 error.
    Can anyone help me with this? Thanks in advance.

    Oracle 8.1.5 working on Sun Solaris 2.6
    Dragon


  2. #2
    Check differences in tnsnames.ora in both remote servers.
    Check in /etc/hosts of two remote servers (maybe it change the IP address)
    Try to do a telnet from the machine client (I mean where tnsping was run)
    Ramon Caballero, DBA, rcaballe@yahoo.com

  3. #3
    Join Date
    Mar 2001
    Posts
    635
    Hi

    Check with you port no to see if it is being used by another process

    Regards
    Santosh

  4. #4
    Join Date
    Feb 2000
    Location
    New York,U.S.A.
    Posts
    245
    Thanks for reply.
    This is what I found perplexed me:
    $ tnsping hubdb

    TNS Ping Utility for Solaris: Version 8.1.5.0.0 - Production on 30-JUL-01 18:19:47

    (c) Copyright 1997 Oracle Corporation. All rights reserved.

    Attempting to contact (ADDRESS=(PROTOCOL=TCP)(HOST=hubdb)(PORT=1521))
    TNS-12541: TNS:no listener

    in the listener.ora file on hubdb the host name is written in IP address format, but tnsping returns HOSTNAME format. Because when I do tnsping and compare with other listener.ora files, whenever HOSTNAME(IP address) in listener.ora file, tnsping will return HOSTNAME(IP address), but never in a mixed format. Other than that, I can not understand why it did not work.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width