Originally posted by tamilselvan
2 Use DIRECT=TRUE option while importing a large data.

I saw 80% reduction in import time when I used DIRECT=TRUE option.
Hardly. There is no such option in import as DIRECT=TRUE. The reduction in import time you noticed was probably because it finished instantly with error message like "Unknown import parameter" . I belive you have mixed up imp and sqlldr.

3 Set the table into NOLOGGING mode.
This will have no effect in import whatsoever.