ORA-12560: TNS: protocol adapter error
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: ORA-12560: TNS: protocol adapter error

  1. #1
    Join Date
    Jul 2001
    Posts
    108

    Question

    Hello,

    The system is generating the error “ORA-12560: TNS: protocol adapter error” when we tried to connect to the oracle database(8.1.7) using SVRMGRL.
    Where as we are able to connect to the database using sqlplus system/manager@bob

    Please help me how to resolve this issue.


    Thanks,
    Nikee

  2. #2
    Join Date
    Jun 2000
    Location
    Chennai/India
    Posts
    90
    Hi,
    Is it an NT or Unix box ? Check the value of ORACLE_SID - this is a O/S variable & set that to U'r Oracle SID.
    A Winner never Quits, A Quitter never Wins
    Ganesh .R

  3. #3
    Join Date
    Jul 2001
    Posts
    108

    Question

    Hello Ganesh,

    Thanks for the reply.
    We are running on WINDOWS 2000 Service pack 2. I have already set the environment variable ORACLE_SID=BOB


    Thanks,
    Nikee

  4. #4
    Join Date
    Jul 2001
    Posts
    108
    Hello Ganesh,

    Here are some addtional information.

    I am able to start the Listener service from windows servives, where as I am unable to start the Listener from the command prompt.
    i.e. lsnrctl start

    At this point system is displaying the following information:
    Starting tnslsnr: please wait..

    Thanks,
    Nikee

    -Nikee

  5. #5
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    Since you are able to connect to the database, through sqlplus that shows that the listeners are up and functional.

    To connect to the server manager fist you would have to

    set ORACLE_SID=bob
    svrmgrl##
    svrmgr> connect internal


    I would suggest that you get accoustom to that of using sqlplus to do the administration as svrmgrl had been discontinued as of 9i.

    set your ORACLE_SID
    sqlplus "/ as sysdba"


    Good luck.
    Sam
    Thanx
    Sam



    Life is a journey, not a destination!


  6. #6
    Join Date
    Jul 2001
    Posts
    108
    Hello SAM,

    Thanks for the suggestion.

    Here I am just investigating the bug source. I am also able to connect to the database using the SVRMGRL but not the first time.

    D:\>svrmgrl

    Oracle Server Manager Release 3.1.7.0.0 - Production

    Copyright (c) 1997, 1999, Oracle Corporation. All Rights Reserved.

    ORA-12560: TNSrotocol adapter error
    SVRMGR> connect internal@bob
    Connected.
    SVRMGR>

    I am just wondering what excatly the error is.

    Thanks.
    Best regards,
    Nikee


    -Nikee

  7. #7
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    That is because you have not set your ORACLE_SID the environment variable.

    D:\> set ORACLE_SID=bob (check the set command syntax)

    Sam

    Thanx
    Sam



    Life is a journey, not a destination!


  8. #8
    Join Date
    Jul 2001
    Posts
    108
    Hello SAM,

    I have already set the environment variable ORACLE_SID=BOB

    Thanks,
    Nikee
    -Nikee

  9. #9
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    So does that mean that its working now?

    Sam
    Thanx
    Sam



    Life is a journey, not a destination!


  10. #10
    Join Date
    Jul 2001
    Posts
    108
    Hello Sam,

    The answer is 'NO, it is not working'.

    I have opened this message after testing all kinds of possibility options.


    Thanks,
    Nikee
    -Nikee

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width