NLS_DATE_FORMAT settings in WIN98!URGENT!
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 6 of 6

Thread: NLS_DATE_FORMAT settings in WIN98!URGENT!

  1. #1
    Join Date
    Feb 2001
    Posts
    286
    Hi!

    I was able to set the NLS_DATE_FORMAT ON NT successfully to-day thus which successfully returns date format in 2001
    whenever we type 2001.

    As we are working on NT OS,I had set the NLS_DATE_FORMAT
    First on the server and then on one of the client's machines successfully by setting the NLS_DATE_FORMAT ON THE ENVIRONMENT SETTINGS ON THE MY COMPUTER PROPERTIES SETTINGS.Thevalue I gave there is:
    NLS_DATE_FORMAT = DD-MON-YYYY(in the ENVIRONMENT settings
    without any quotes,mind you for this).

    Queries:

    1.Now please let me know how to set the same settings on WIN98/WIN95 as we are having few NT machines and more WIN98s.There are no environment settings on WIN98.
    So where should I have to SET NLS_DATE_FORMAT on WIN98
    CLIENT's machines.

    This is extremely important for our Project!

    Regards,

    Amitstora.

  2. #2
    Join Date
    Dec 2000
    Location
    Ljubljana, Slovenia
    Posts
    4,439
    You can set it in your computser environment, as you did it, but generaly you would set it in the registry (both in NT/2000 or 95,98). Run regedit.exe, then go to HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE. You can then set it in each of your ORACLE_HOME entries, each ORACLE_HOME can have its own, separate seting for whatever environment variable you want.
    Jurij Modic
    ASCII a stupid question, get a stupid ANSI
    24 hours in a day .... 24 beer in a case .... coincidence?

  3. #3
    Join Date
    Feb 2001
    Posts
    286

    Hi Jmodic!Problem setting NLS_DATE_FORMAT IN THE REGISTRY SETTING ON WIN98!URGENT!

    Hi Jmodic!

    I had tried both ways i.e.,by setting new key in the registry in HKEY_LOCAL_MACHINE/SOFTWARE/ORACLE/ORACLE_HOME
    and also by setting in the new string as:

    variable name:NLS_DATE_FORMAT
    VALUED-MON-YYYY

    On the other hand,I had also set it permanently in the INIT.ORA Parameter File.But still I am not getting the date format in 2001!

    What else should I do!

    Could you please explain me step by step the setting of both registry and INIT.ORA Files for NLS_DATE_FORMAT.

    Regards,

    Amitstora.


  4. #4
    Join Date
    Mar 2001
    Posts
    188
    Hi,
    after you set this variable you mast stop and start you db again. Than your values are real.
    I don't know if you change somethink in the registry if you must reboot your os.
    Best Regards
    Thomas Schmidt

    Thomas_Schmidt@eplus-online.de
    If you have no aims, you will never reach a goal !!!

  5. #5
    Join Date
    Dec 2000
    Location
    Ljubljana, Slovenia
    Posts
    4,439

    Re: Hi Jmodic!Problem setting NLS_DATE_FORMAT IN THE REGISTRY SETTING ON WIN98!URGENT!

    Originally posted by amitstora
    I had tried both ways i.e.,by setting new key in the registry in HKEY_LOCAL_MACHINE/SOFTWARE/ORACLE/ORACLE_HOME
    and also by setting in the new string as:

    variable name:NLS_DATE_FORMAT
    VALUED-MON-YYYY
    I'm not sure I understand exactly what you have done, but I suspect you have set the NLS_DATE_FORMAT variable in the registry keyHKEY_LOCAL_MACHINE/SOFTWARE/ORACLE/ORACLE_HOMES, which is not correct place for this setting. Set it in the following key:
    HKEY_LOCAL_MACHINE/SOFTWARE/ORACLE/HOME0. If you have more than one oracle_home then it might also be HOME1 or HOME2 or HOMEn instead of HOME0 - determine which home is the right one for the tool/aplication you are using and set NLS_DATE_FORMAT there.
    Jurij Modic
    ASCII a stupid question, get a stupid ANSI
    24 hours in a day .... 24 beer in a case .... coincidence?

  6. #6
    Join Date
    Sep 2000
    Posts
    305
    I think if you change only in the registry it will work or you have to add at both the palces because I have tried here only in the registry is is working.

    plz. tell me


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width