Turn Archiving Off Safely whilst import is done..
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 7 of 7

Thread: Turn Archiving Off Safely whilst import is done..

  1. #1
    Join Date
    Apr 2001
    Location
    London
    Posts
    725
    Hi friends..

    One of my colleagues needed to turn archiving off whilst he did a large import.

    He set log_archive_start to false and bounced the server.

    when the system restarted the database hung..

    Does anybody know the corect procedure for turning archive mode off (safely) whilst a large import is taking place.
    And then restarting arhive mode after the import has been done.

    Also..

    does anybody know why the database would have hung (what technically happened?) if the archiving was simply set to false and the database was bounced

    Many Thanks

    Suresh

  2. #2
    Join Date
    Feb 2001
    Posts
    75

    archiving start & stop

    Hi,

    There is no reason for DB to hung in what your firend did. May be your online redo is large and DB was taking time in instance recovery. Or may be the shutdown was not clean & complete. You may have such problems if the shared mem & semaphores are not cleared. Try ipcs & icprm ( carefully).

    The procedure of starting & stoping archiving is through thsi init.ora parameter only so what he did is right.

    Kailash pareek

  3. #3
    Join Date
    Nov 2000
    Location
    greenwich.ct.us
    Posts
    9,092
    Did you ALTER DATABASE NOARCHIVELOG?

    log_archive_start only signifies whether you want automatic archiving of your logs or not.
    Jeff Hunter
    marist89@yahoo.com
    http://marist89.blogspot.com/
    Get Firefox!
    "I pledge to stop eating sharks fin soup and will not do so under any circumstances."

  4. #4
    Join Date
    Aug 2000
    Posts
    194
    As, Jeff noted it might be waiting for the manual archiving becaz the auto archival is disabled and the archivemode itself is not disabled.

    Query the V$DATABSE (I guess its V$DATABASE LOG_MODE column) to see whether its really disabled.


  5. #5
    Join Date
    Mar 2001
    Posts
    314
    My 2c's:

    I am not sure if I understood Suresh's posting clearly or not. However as I understood what he wants to know is "how to turn off archiving WHILE import is GOING ON".
    Having said that, when Suresh said that the init.ora file was modified and the DB bounced, I assume that it was done with the abort option (otherwise it can't be done right? the import is still going on!).
    So, the the DB was restarted, oracle was doing instance recovery (must have been a large table which was being imported) and so it seemed that the DB had hung.
    As far as setting archiving off, Jeff has already pointed out what to do.

    -amar

  6. #6
    Join Date
    Apr 2001
    Location
    London
    Posts
    725

    Thanks

    Hi Friends,

    User did not 'alter database noarchivelog'

    He changed log_archive_start to false and shut down (immediate) and then restarted the database. On restart the database hung for a little while.


    I have told him that next time he needs to turn archivelog off to :

    Shut down db.
    startup mount exclusive
    connect internal
    alter database noarchivelog
    alter database open

    and to restart :

    shut down db
    startup mount exclusive
    connect internal
    alter database archivelog
    alter database open


    Does this sound right ?


    Thanks for your help guys..

    Suresh




  7. #7
    Join Date
    Nov 2000
    Location
    greenwich.ct.us
    Posts
    9,092
    Sounds reasonable to me.
    Jeff Hunter
    marist89@yahoo.com
    http://marist89.blogspot.com/
    Get Firefox!
    "I pledge to stop eating sharks fin soup and will not do so under any circumstances."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width