How can I set the Shared Memory and Semaphore segments?
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 6 of 6

Thread: How can I set the Shared Memory and Semaphore segments?

  1. #1
    Join Date
    Mar 2001
    Posts
    40
    Hi all,

    I want to install Oracle8.1.5 to Sun Solaris 2.7(Sparc), but after I added the parameter to the /etc/system of file, there allways come with the error of 'not defined the shmsys' while OS starting up. How can i work out of it? thanks.

    -mike

  2. #2
    Join Date
    Feb 2000
    Posts
    175
    Hi,

    What is are the exact lines you are entering in the /etc/system file?

    Moff

  3. #3
    Join Date
    May 2001
    Location
    India
    Posts
    55

    /etc/system settings for solaris 2.7

    Hi,

    This is the setting for Oracle 8.1.5. you have to set following parameters in the /etc/system.

    set shmsys:shminfo_shmmax=256000000
    set shmsys:shminfo_shmmin=1
    set shmsys:shminfo_shmmni=100
    set shmsys:shminfo_shmseg=10
    set semsys:seminfo_semmns=200
    set semsys:seminfo_semmni=70

    already I done it same configuration in oracle 8.1.6 and solaris 2.8. That is working good. You worry about this, just you have to set same configuration, defenitely it will work.

    G.Shankar.

  4. #4
    Join Date
    Feb 2000
    Posts
    175
    Hi,

    I would suggest you read the installation manual for the definitions (downloadable from technet) to ensure your system is configured correctly
    eg number of semaphores - which could differ depending on the application your running.
    However, below are the lines I've entered for my installation and I've had no problems.

    set shmsys:shminfo_shmmax=4294967295
    set shmsys:shminfo_shmmin=1
    set shmsys:shminfo_shmmni=200
    set shmsys:shminfo_shmseg=200
    set semsys:seminfo_semmni=300
    set semsys:seminfo_semmsl=150
    set semsys:seminfo_semmns=300
    set semsys:seminfo_semopm=200
    set semsys:seminfo_semvmx=32767

    Cheers

    Moff

  5. #5
    Join Date
    Mar 2001
    Posts
    40

    ORA-01012: NOT LOGGED ON

    Thank you all!
    I just changed my display and the Shared Memory parameter is set correctly. but there is another error occured with 'ORA-01012:NOT LOGGED ON', I have no ideas about it now, I was wondering if I could appeal to your good nature and ask you to help me out. TIA.

    -mike

  6. #6
    Join Date
    Feb 2000
    Posts
    175
    Hi,

    When does this error occur?

    Moff

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width