8.1.6 on Win2000 - Problems
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2

Thread: 8.1.6 on Win2000 - Problems

  1. #1
    Join Date
    Aug 2000
    Posts
    236
    I had a production server running 8.1.6 on NT Server and all was fine.

    Last week, I upgraded NT Server to Win 200 server with Oracle still on the system. After upgrading, I notice that the OracleServiceSID is hanging. The status of service is 'STARTING'. It has been like that for 2 days now.

    I am forced to go to server manager and start the instance & open database. Even though the service startup is set to automatic, the database does not come up.

    Is this a known issue and are there any workarounds for this. Pleasse treat this as urgent.

    Thanks/Regards,
    Nizar.

  2. #2
    Join Date
    Jul 2000
    Posts
    243
    Hi

    i found this on the metalink. i hope it helps.

    The bug 1266248 with Abstract: ORACLESERVICE FAILS TO AUTOMATICALLY START THE DATABASE reads as this is fixed in v8.1.7.
    Could refer to the following article:
    136214.1 startup and shutdown related registry entry's for 8i
    132086.1 ORACLESERVICE FAILS TO AUTOMATICALLY START THE DATABASE AFTER REBOOT
    Make sure the variable ora_SID_autostart is set in the correct location in the registry:

    hkey_local_machine/software/oracle/homexx (xx=home number)

    Make sure that the variable ora_SID_pfile points to the correct location of your pfile, specifying the full path.

    If the above doesn't work, then follow these steps to troubleshoot:
    Is the service itself starting successfully (can you connect to the instance and start it manually without manually starting the OracleServiceSID)? Check the task manager and see if two ORADIM.EXE is listed as an active process, one for each instance.

    Was this an upgrade from WIN NT to Win2000? If you still have problems, suggestyou drop and create your instance/service. You will have to shutdown the database to do this. During the upgrade process, the disk is converted to NTFS 5 and a different access authorization is used instead of the old Security Account Manager (SAM). The new services autostart, but they no longer hold the same NT permissions as before, even though they are running under the system account.

    oradim -delete -sid SID
    oradim -new -sid SID -intpwd PASSWORD

    61621.1 WINNT/WIN2000 Recreating Oracle Services and Instances
    62006.1 Troubleshooting Tips Database Not Autostarting

    If the startup continues to fail, check the OS event log (application and system) to see what might be logged on the failure. There is also an oradim.log in the %oracle_home%\database directory that may or may not have useful information.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width