Oracle Agent on NT
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 6 of 6

Thread: Oracle Agent on NT

  1. #1
    Join Date
    Nov 2000
    Posts
    39
    I was wondering if anyone have seen this problem:

    I'm running Oracle 8.1.7 on NT 4.0, sp6a. Oracle Service and Agent are set up to start automatically.
    1. Shut down the db.
    2. Shut down the server.
    3. Boot up the server.
    4. Log on to the domain.
    5. After about 2 min., I get an error message: "One of the srvices failed at startup, check the Event Log". It turns out to be the Oracle Agent. The error message in the Event Viewer is: "Oracle Agent hung on startup". When I check the services, the Agent starts up right away after the login. It stays up and running.

    Any help would be most appreciated.

  2. #2
    Join Date
    Feb 2000
    Location
    Washington DC
    Posts
    1,843
    Did you try stopping and restarting from Services or from lsnrctl command line ? Try stopping and restarting and see.
    Reddy,Sam

  3. #3
    Join Date
    Nov 2000
    Posts
    39
    Thanks for reply.

    I don't have to do start service from lsnrctl since the service gets started automatically when NT boots up.

    I'm just wondering what that anoying error message means and how to get rid of it...

  4. #4
    Join Date
    Apr 2001
    Posts
    107
    Hi,

    I've got exactly the same pb with 8.1.7 agent/server at boot: error message, event log saying that agent does not start, but it starts anyway (maybe a little later?)

    No solution though, sorry...

    cheers

  5. #5
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    Did you folks try using the net to try starting and stopping the agent. In windows, using the lsnrctl had no effect on starting the listener. You would use the net command to start and stop applications on the windows. Here is how you use the net to start and stop the agent


    c:> net start OracleAgent80

    c:> net stop OracleAgent80


    To find the list of services that you can start or stop,

    use

    c:> net help services

    To get help on command try:

    c:> net help command

    To read help page one at a time

    c:> net help command | more

    Here are some of the commands that can be useful to you.



    NET ACCOUNTS
    NET HELP
    NET SHARE
    NET COMPUTER
    NET HELPMSG
    NET START
    NET CONFIG
    NET LOCALGROUP
    NET STATISTICS
    NET CONFIG SERVER
    NET NAME
    NET STOP
    NET CONFIG WORKSTATION
    NET PAUSE
    NET TIME
    NET CONTINUE
    NET PRINT
    NET USE
    NET FILE
    NET SEND
    NET USER
    NET GROUP
    NET SESSION
    NET VIEW


    If you have any problems, please let us know. Hope this would help you folks.

    Sam
    Thanx
    Sam



    Life is a journey, not a destination!


  6. #6
    Join Date
    Nov 2000
    Posts
    39
    I have no problem starting the Agent eitehr way (through Services or NetStart). My problem is the error message I'm getting from NT even though the Agent is started. I know that the agent is runnign bcause I can ping it.

    Is it one of these things we should blame Bill Gates for :-)?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width