Privileges
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2

Thread: Privileges

  1. #1
    Join Date
    Nov 2000
    Posts
    178
    Hello All!,

    I'm creating a materialized view and having the following problems:

    When I create the view with ENABLE QUERY REWRITE option I get the this error message: ORA-01031: insufficient privileges. I tried this: GRANT REWRITE ON 'table_name' TO 'user' while connected as user sys but was still getting the error. I also tried this command (with GLOBAL): GRANT GLOBAL QUERY REWRITE but the SQL*Plus kept returning an error message: ORA-00990: missing or invalid privilege.

    What I really want to do is to create a materialized view that will on refresh increamentally after laoding data. I'm sure someone out there has done this before me so PLEASE HELP!!!



    [Edited by ac on 05-30-2001 at 08:08 AM]

  2. #2
    Join Date
    Nov 2000
    Posts
    178
    Hi all,

    I guess I'm not the first person to handle materialized view so can somebody out there help please!!!?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width