Urget Help in Listener and TNS
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: Urget Help in Listener and TNS

  1. #1
    Join Date
    May 2001
    Posts
    19
    Hi Fellows,

    I created a New Database with name DBAsma on Win2000/8.1.6 It worked fine.

    I changed the entries in TNSnames, and Listener for the New database and then I used SQL *Plus to login it woked even for both Databases.

    This morning I started the Machine again and tried to login, but it gives me error from TNS .

    Fatal NI connect error 12541, connecting to:
    (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=asmacomp)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=DBAsma)(C ID=(PROGRAM=C:\Documents and Settings\Administrator.ASMACOMP\Desktop\Ezsql.exe)(HOST=ASMACOMP)(USER=Administrator))))

    VERSION INFORMATION:
    TNS for 32-bit Windows: Version 8.1.6.0.0 - Production
    Windows NT TCP/IP NT Protocol Adapter for 32-bit Windows: Version 8.1.6.0.0 - Production
    Time: 16-MAY-2001 09:31:56
    Tracing not turned on.
    Tns error struct:
    nr err code: 0
    ns main err code: 12541
    TNS-12541: TNS:no listener
    ns secondary err code: 12560
    nt main err code: 511
    TNS-00511: No listener
    nt secondary err code: 61
    nt OS err code: 0

    If I use Dos and set the Oracle_Sid=DBAsma and hen start Svrmgr and login as Internal it login to DBAsma.

    In registry the Oracle_Sid = DBQais (Which is the Other Database) In services Listener is running Automatic.

    can any one please suggest me what's wrong there.

    Thanks and Regards.

  2. #2
    Join Date
    Jun 2000
    Posts
    417
    Is the listener for DBAsma running?

  3. #3
    Join Date
    May 2001
    Posts
    19
    How can i Check that.. I checked the Services it's runing and there is entry in Registry for DBAsma just like DBQais.. I suppose yes.

  4. #4
    Join Date
    Jun 2000
    Posts
    417
    On NT I can't really say, I've only administered on Unix, you might try bouncing it though just be sure, the errors seem to point to the fact that the listener isn't up.

  5. #5
    Join Date
    Nov 2000
    Posts
    344
    Check the listener by going to a dos prompt and typing in :

    lsnrctl status

    If it is not running, issue

    lsnrctl start

    In NT, even if the SERVICE shows the listener is running,
    that doesn't mean that the listener is really running. The
    only way to know for sure is with lsnrctl.

    -John

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width