ORA-12154 for non-oracle users
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 6 of 6

Thread: ORA-12154 for non-oracle users

  1. #1
    Join Date
    Oct 2000
    Posts
    48
    We are using Oracle 8.1.6.3 on Sun. Anytime a user other than oracle tries to connect to sqlplus using Net8 they receive an ORA-12154 error:

    sqlplus jsmith@alfred_test

    SQL*Plus: Release 8.1.6.0.0 - Production on Fri May 11 11:00:33 2001

    (c) Copyright 1999 Oracle Corporation. All rights reserved.

    Enter password:
    ERROR:
    ORA-12154: TNS:could not resolve service name

    Since the oracle user can make such connections, I figured the other users did not have permission to read tnsnames.ora, but I have verified that that file has read permission for the world. Also, I have tried setting their TNS_ADMIN env variable to point to $ORACLE_HOME/network/admin directory even though I shouldn't have to, but that doesn't help.

    Below is the entry from the tnsnames.ora file that was created using the Net8 Configuration Assistant:

    ALFRED_TEST.DB.VT.EDU =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = alfred.db.vt.edu)(PORT = 1521))
    )
    (CONNECT_DATA =
    (SERVICE_NAME = TEST)

    Any idea on what the problem is???


  2. #2
    Join Date
    Mar 2000
    Location
    Chennai.Tamilnadu.India.
    Posts
    658

    Investigate

    Hi, 11th May 2001 20:48 hrs *******

    ======================
    ALFRED_TEST.DB.VT.EDU =
    ======================
    Check in your sqlnet.ora the parameter

    from TNSNAMES.ORA
    ===============
    EXTPROC_CONNECTION_DATA.ORACLE11I =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
    )
    (CONNECT_DATA =
    (SID = PLSExtProc)
    (PRESENTATION = RO)
    )
    )
    ================

    From My SQLNET.ORA

    NAMES.DEFAULT_DOMAIN = ORACLE11I(NOT COMMENTED)
    Look from both the TNS and SQLNET files .

    I had a ||r problem once may be this could also be one of the reasons.

    Cheers

    Padmam
    Attitude:Attack every problem with enthusiasam ...as if your survival depends upon it

  3. #3
    Join Date
    Oct 2000
    Posts
    48
    Removing the DB.VT.EDU extension from the service name solved the problem of other users not being able to connect through sqlnet. But why?? Why didn't this affect the oracle user's connection? And why did the Net8 Config Asst set this? BTW, other users had been able to connect before even when the DB.VT.EDU was still appended to the service name in tnsnames.ora. But obviously something has been changed, I just can't figure out what.

  4. #4
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    It could be because you have not defined the domain name in the sqlnet.ora file under $ORACLE_HOME/network/admin


    Sam
    Thanx
    Sam



    Life is a journey, not a destination!


  5. #5
    Join Date
    Oct 2000
    Posts
    48
    Well, I actually had "NAMES.DEFAULT_DOMAIN = db.vt.edu" commented out of sqlnet.ora because we couldn't get Net8 connections to work until we did that. So right now, even with the DB.VT.EDU extension removed from tnsnames.ora and NAMES.DEFAULT_DOMAIN commented out of sqlnet.ora, all users can make a Net8 connection. And a short while ago, with the NAMES.DEFAULT_DOMAIN still uncommented out everybody could connect even when the DB.VT.EDU extension in tnsnames.ora. Like I said, don't know what changed from then to now, but something did. But as long as it works now with the DB.VT.EDU removed, I'm happy. I'm just confused as to how this problem never affected the oracle user.....


  6. #6
    Join Date
    Mar 2000
    Location
    Chennai.Tamilnadu.India.
    Posts
    658

    Host

    Hi, 11th May 2001 21:51 hrs *******

    Are your users connected via Host naming ?

    Try in SQLNET.ORA remove the other two options except tnsnames....

    Cheers

    padmam
    Attitude:Attack every problem with enthusiasam ...as if your survival depends upon it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width