help needed with archival information
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: help needed with archival information

  1. #1
    Join Date
    Mar 2001
    Posts
    78

    Post

    This is how I have set my archival information in my init.ora file

    log_archive_start = true
    log_archive_dest = /u09/ora09/PRISCRIPTION/archive
    log_archive_duplex_dest = /pharmacy/PRESCRIPTION/archive
    log_archive_format = "arch%S.arc"

    I have realized that the archive log files in this directory:
    log_archive_dest = /u09/ora09/PRISCRIPTION/archive are 50 files
    while the ones in this directory /pharmarcy/PRISCRIPTION/archive for the duplex is 180 files.
    Can any one explain that?

    [Edited by panjub_raj on 05-08-2001 at 05:21 PM]

  2. #2
    Join Date
    Oct 2000
    Location
    Dallas:TX:USA
    Posts
    407
    there are two possibilites --

    1. Someone deleted a bunch of files
    2. The values of the archival parameters (log_archive_dest and log_archive_duplex_dest ) were changed without your knowledge.

    For example, I am testing this right now on my test server, changing these parameters, bouncing the instance etc. and the net result is their are unequal number of files in the two directories.

    - Rajeev
    Rajeev Suri

  3. #3
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    Is there any backup going on? If so, what had been happening was that you are deleting the archive log files from the directory with the less number of archive and not doing the deletion on the other. If you are using RMAN then you have to delete the files from the other directory too.


    Sam
    Thanx
    Sam



    Life is a journey, not a destination!


  4. #4
    Join Date
    Mar 2001
    Posts
    78
    No I am not using RMAN. I do a cold backup every evening and I also do export the entire database every evening

  5. #5
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    O.K on such case do you get to delete the archive log files? If so, you would have deleted on one and not on the other.


    Now to be on the safer side, shutdown your database, take a cold backup, delete all the archive logs on both the directories and then start the instance. That shiuld put you back in sync.

    Sam
    Thanx
    Sam



    Life is a journey, not a destination!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width